strace crash (TLS data not initializing?)

Daniel Santos
Sat Apr 15 11:17:00 GMT 2017

On 04/14/2017 10:49 PM, Dan Kegel wrote:
> On Fri, Apr 14, 2017 at 8:41 PM, Daniel Santos <> wrote:
>> oops, I meant -g3 :)
> That was suboptimal of you
> /me ducks

/me swings

> /me ducks

/me misses, damn!

> strace ls doesn't die for me with plain old cygwin installed a while ago.
> Is this only with fresh cygwin?

Well, I installed this only about 2 months ago to do gcc testing -- what 
a fun ride that was!  While waiting for the last three P1 gcc bugs to 
get solved (so they can release gcc7 and open up gcc8 stage1) I decided 
to troubleshoot expect ... except that I didn't expect to have to fix 
this strace thing.... DAMN, I really need to work on being brief and 

So yes, fairly a new install.  Also, it's in a qemu/kvm vm, not that 
that should matter (with virtio sata driver).  So maybe I should try to 
debug where ever that TLS data is supposed to get initialized. Also, 
this is one of those things that didn't happen much when I was actually 
debugging strace, but at least it is now.  This is on 64-bit Cygwin.  I 
just tried on 32-bit a few times and it's working.

On the bright side, better understanding Cygwin's internals will help me 
be a better Wine programmer.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list