Link error with static version of zlib?

J (Jean-Claude Gervais)
Mon Jul 24 23:55:00 GMT 2017

Hello Steven and Hans-Bernhard,

I believe the problem stems from a missing component in the runtime.

When I use Gentoo's Crossdev and generate either the 32 or 64 bit
version of MinGW, it allows me to compile and link the app with no
other dependencies than msvcrt.dll. I can run the cross-compiled app
directly on Windows.

But for some reason, the MinGW compiler present in Cygwin looks for
threading support which is not there.

This is strange because I manually compiled the source for both
libraries (zlib with minizip in the contrib folder) and it gives the
same error.

Searching the source for any mention of threads in the code yields
nothing except comments about whether routines are thread-safe or not.

The link complains about those functions missing from libpthread.a,
even though that library is not invoked.

I've tried linking the pthread library, but it does not supply the
missing symbols.

So those symbols have to either be present in a lib that is missing
from the link-line, which would be strange because the same link-line
works with the linux version of MinGW


the runtime library needs to supply them?

I'll try and narrow it down more.

Thank you both for your help.


On Thu, 2017-07-20 at 18:01 -0700, Steven Penny wrote:
> On Thu, 20 Jul 2017 20:59:00, =?UTF-8?Q?Hans-Bernhard_Br=c3=b6ker?=
> wrote:
> > And that's where you went off in the wrong direction.  You're
> > writing to 
> > the Cygwin mailing, but that's the MSYS2 package repository.  Those
> > are 
> > two different environments, so you should _not_ mix up them up like
> > that.
> This is a pretty awful response. The MSYS2 part of my answer, the
> part OP tried
> is certainly possible. When Cygwin package maintainers are ignoring
> serious
> package issues for months:
> -
> -
> -
> -
> -
> it is not wrong to seek a sane alternative, which this is. You
> certainly can mix
> these as in this case we are not involving the Cygwin DLL. To J (OP),
> if you
> want a real answer and not this brush off, repost your question here
> and I will
> try to work with you:
> as technically your original question has already been answered (by
> me), and
> your new issue is outside the scope of this mailing list.
> --
> Problem reports:
> FAQ:         
> Documentation:
> Unsubscribe info:

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list