how to access and display apps that I've launched

mike mikereape@onetel.com
Tue Jul 25 02:16:00 GMT 2017


On 24/07/2017 18:02, Brian Inglis wrote:
> On 2017-07-23 13:18, mike wrote:
>> On 23/07/2017 19:14, Brian Inglis wrote:
>>> On 2017-07-23 11:39, mike wrote:
>>>> On 23/07/2017 16:58, Jack wrote:
>>>>> On 2017.07.23 08:32, mike wrote:
>>>>>> Hi
>>>>>>
>>>>>> I updated my Cywin installation on the 21st or 22nd of July 2017.  I run
>>>>>> 32-bit Cygwin/X on 64-bit Win 7 Pro.  If I launch the Cygwin Xwin Server I
>>>>>> get the icon at the very top middle of the screen and can then go into the
>>>>>> icons menu and right click on the Cygwin icon and get a list of categories of
>>>>>> applications to run and apparently launch because if I try to launch some and
>>>>>> wait long enough and right click on the aforementioned icon and select quit
>>>>>> it says there are N apps running and do I want to close them.  The problem is
>>>>>> that anything I launch through the icons menu doesn't display anywhere and in
>>>>>> particular doesn't appear in the task bar.  I have read the FAQ and UG but
>>>>>> can't find what I'm looking for.  It definitely seems to me that the
>>>>>> behaviour has changed since before I updated.
>>>>>>
>>>>>> Can somebody please tell me what I am doing wrong?  I would be very grateful
>>>>>> for any help.  Thanks in advance.
>>>>>>
>>>>>> Mike
>>>>> Are you sure those apps you are trying to launch are actually installed?  You
>>>>> could always bring up a Cygwin terminal (not through the X icon) and
>>>>> explicitly "export DISPLAY=0:0" and then try to launch one of the apps from
>>>>> the command line to see any errors.
>>>>>
>>>>> Jack
>>>> All I did was download setup-x86.exe on the 21st, run it and when presented with
>>>> the drop down View list used Pending (by default) and then clicked Next etc.  If
>>>> I switch to Up To Date when presented with the drop down View list it does
>>>> indeed show that everything I've tried to run is installed.  I must have
>>>> hundreds of packages installed.  I did that last year intentionally.  I selected
>>>> packages to install by Category and then installed the entire Categories. That's
>>>> what I'm saying all this stuff used to just work and now it just doesn't so I'm
>>>> either completely missing the obvious or else it really seems like something is
>>>> wrong with my installation or the behaviour has changed.  If I'm just missing
>>>> the obvious then please just tell me where I'm going wrong.
>>>>
>>>> I do not want to uninstall everything and then re-install because I have no
>>>> confidence that that will solve the problem.  To repeat the Cygwin/X icon is
>>>> there and the menu is there.  The packages that I am most immediately interested
>>>> in are the Cygwin Emacs packages which are clearly in the Up To Date list.  If
>>>> the packages aren't installed then why would they show up in the menu?  If I
>>>> look in C:\cygwin\bin I can see among others emacsclient-nox.exe,
>>>> emacsclient-X11.exe, emacs-nox.exe and emacs-X11.exe so they're installed right?
>>> May have run out of DLL address space.
>>> Run "rebase-trigger full", shut down everything Cygwin, download and run
>>> setup-x86, then check /var/log/setup.log.full for rebase problems.
>>>
>> I wasn't running anything Cygwin when I ran setup-x86.exe on the 21st.  I've
>> attached /var/log/setup.log.full.  There is no occurrence of the word rebase
> The log indicates it only downloaded the mirror list and setup.ini and updated
> nothing. That's why you should run "rebase-trigger full" then run setup-x86.
>
Could you please then tell me how to do that?  I should point out that 
almost every time (or maybe every time) I've tried to update Cygwin in 
the past (going back quite a long way) some part of the 
post-installation scripts fails and I have to run setup-x86.exe again 
and then it finishes properly.

Thanks, Mike

-- 
I *AM* a unique and special snowflake


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list