[ANNOUNCEMENT] Updated: libreadline7-7.0.3-3

David Macek david.macek.0@gmail.com
Mon Jul 31 20:05:00 GMT 2017


On 31. 7. 2017 11:48, Corinna Vinschen wrote:
> Well, it works for me.  I tested this in tcsh, bash and od on
> Windows 10.

I tested on Windows 2012 R2 (8.1 equivalent) and I can confirm Steven's findings.  Tried with an older installation and then once more after a complete update (`uname -a`s below).

- CYGWIN_NT-6.3 computername 2.8.0(0.309/5/3) 2017-04-01 20:47 x86_64 Cygwin
- CYGWIN_NT-6.3 computername 2.8.2(0.313/5/3) 2017-07-12 10:58 x86_64 Cygwin

>> - Alt 148 outputs nothing
>> - Alt 0246 outputs nothing
>> - Pasting this character does not work

I ran Cygwin from a clean command window (`cmd /d`) using `chcp ...` and `bin\bash -li`.  The ö's don't appear in bash with CP 65001. Other combinations (bash with CP 437, cmd with either CP) allow ö's to appear.

Try the legacy console (conhost v1), if you haven't already.  Maybe it will show the same behavior even on Windows 10.

-- 
David Macek

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3715 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://cygwin.com/pipermail/cygwin/attachments/20170731/30930d10/attachment.p7s>


More information about the Cygwin mailing list