Problems with mintty jump list

Thomas Wolff towo@towo.net
Sun May 13 21:05:00 GMT 2018


Am 13.05.2018 um 16:37 schrieb Michael Schaap:
> On 13 May 18 11:45, Thomas Wolff wrote:
>> Am 12.05.2018 um 19:15 schrieb Brian Inglis:
>>> On 2018-05-12 06:28, Michael Schaap wrote:
>>>> I'm experimenting with the new mintty jump list feature, but I'm 
>>>> having trouble
>>>> getting things working.
>>>> I've added the following to my .minttyrc:
>>>>      TaskCommands=default:-p 100,100;myserver:-p bottom -p right -o
>>>> BackgroundColour=255,250,230 -e /usr/bin/ssh -C -Y -o 
>>>> ServerAliveInterval=60
>>>> myserver.example.org
>>>> I then started mintty with:
>>>>      mintty -o AppID=minttytest
>>>> The MinTTY window appeared, with a new icon on the task bar. I 
>>>> pinned that
>>>> icon, and closed this new window.
>>>> A right click on the taskbar icon now indeed shows two jump list 
>>>> entries:
>>>> default and myserver.
>>>> But when I click on "default", a MinTTY window does open and runs 
>>>> my shell
>>>> (which is zsh), but the environment is different than normal: for 
>>>> instance,
>>>> /usr/bin is not in the $PATH and most commands are therefore not 
>>>> found.  (It's
>>>> not running as a login shell?)
>> Yes, as you most likely want to run a login shell, you should add a 
>> bare '-' to the arguments list, like
>>
>> TaskCommands=default:-p 100,100 -;...
>
> Indeed, that helped.
> I was a bit confused about why I needed this here, and not when 
> running MinTTY "normally", but then I saw that the default shortcut 
> also had this argument.
>
>>
>>>> When I close all MinTTY windows, the icon remains on the taskbar 
>>>> (as it should),
>>>> but the jump list entries are gone.
>>>> What am I doing wrong?
>> Nothing. I have no idea why this fails, in my testing it worked. On 
>> the other hand, the whole jump list showed up on only 2 of 3 test 
>> systems and failed on one. Mozilla applications (Thunderbird, 
>> Firefox) manage to establish a task list on all of these systems, but 
>> their jumplist code looks much more complex. If someone finds out by 
>> what cursed Microsoft magic this is further affected, I'd consider an 
>> enhancement...
>
> I got things working.  :-)
> I noted that the entries disappeared from the list as soon as I 
> clicked on one of them.  I eventually tried adding "-o AppID=..." to 
> the arguments in TaskCommands, and that helped: the entries remained.
> The only remaining problem was that the entries still disappeared when 
> clicking on "Terminal" (or simply clicking on the pinned taskbar item 
> with no terminal windows open), so I added AppName and AppLaunchCmd 
> options to .minttyrc, and that did the trick.
>
> So, in the end, I added these lines to ~/.minttyrc:
>
>     TaskCommands=default:-o AppID=mymintty -p 1170,605 -;myserver:-o 
> AppID=mymintty -p bottom -p right -o BackgroundColour=255,250,230 -e 
> /usr/bin/ssh -C -Y -o ServerAliveInterval=60 myserver.example.org
>     AppName=Terminal
>     AppLaunchCmd=C:\cygwin64\bin\mintty.exe -o AppID=mymintty -
>
> then started MinTTY with this shortcut:
>
>     C:\cygwin64\bin\mintty.exe -o AppID=mymintty 
> --store-taskbar-properties -
>
> and pinned it to the taskbar.
>
> Thanks for your help (and for providing the awesome MinTTY in general!),
>
>  – Michael
>
> PS: PuTTY also supports the jump list, both "Recent Sessions" and a 
> couple of fixed "Tasks", this appears to work fine.  I'm sure you're 
> more familiar with the PuTTY source code than that of Mozilla apps, so 
> perhaps it helps to take a look at how PuTTY's doing this?
Thanks, maybe jumplist-started instances should implicitly inherit AppID.
Are you sure --store-taskbar-properties is needed to get the jumplist 
stable? This would have additional implications, to be checked.
Thomas

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list