Updated: fetchmail-6.4.14-1

Stephen Carrier carrier@berkeley.edu
Mon Dec 7 17:28:04 GMT 2020


On Fri, Dec 04, 2020 at 05:21:14PM -0800, L A Walsh wrote:
> On 2020/12/04 12:18, Achim Gratz wrote:
> > L A Walsh writes:
> > >    I see no reference to any python of any version.
> > 
> > Yes, the package does depend on it, and as noted in the announcement it depends specifically on python36.
> ----
>    So, people who configure fetchmail with the man page and have never used
> fetchmailconf should get in the habit of ignoring package requirements?  Not
> sure
> how good that is.

Today I learned there is a thing called fetchmailconf and I've been using
fetchmail for years.  I agree that it should be unbundled, as python is
big dependency and manual configuration is pretty simple.

For precedent, my Fedora doesn't bundle fetchmailconf with fetchmail.
Maybe more recent Fedora versions than mine do this; I don't know.

In general, I think dependencies larger than the package it supports,
that are supporting only a non-core feature, ought to have that non-core
feature unbundled.

Stephen


More information about the Cygwin mailing list