Rsync + SSH slow speed

Luis Gonzalez
Thu Dec 17 18:43:04 GMT 2020

I have tried new things.
I have copied deltaCopy into cygwin64 directory
when i made the rsync command i use the rsync from deltacopy
(--rsync-path=/DeltaCopy/rsync.exe )
/usr/bin/rsync -rlptDvh  --partial --del --progress -s --ignore-errors
--rsync-path=/DeltaCopy/rsync.exe  -og --timeout=500
--rsh='ssh -p 2230  -o CheckHostIP=no  -o Compression=no '
Administrator@host:/cygdrive/ /dst/client/

with this configuration the speed goes to 30MBps  :-OOOOOO
i supposed that this version of rsync is optimized for speed.
best regards

El vie, 11 dic 2020 a las 11:59, Luis Gonzalez
(<>) escribió:
> Hi to everybody,
> i have several windows server in different location with the  latest
> version of cygwin with open ssh and rsync installed openssh 8.4p1-2
> rsync  3.2.4dev
> i'm trying to rsync from centos with rsync 3.2.3
> The problem is that if i use rsync
> /usr/bin/rsync -rlptDvh  --partial --del --progress -s --ignore-errors
>   -og --timeout=500 --include-from=/scripts/clients/pattern.txt
> --rsh='ssh -p 2230  -o CheckHostIP=no  -o Compression=no '
> Administrator@host:/cygdrive/ /dst/client/
> speed is only above 2.0MBps. CPu is over 5%, hard disk is about 1% and
> network speed is about 2%
> if i made the same rsync over linux machine on the same location speed
> is up to 60MBps(network speed on both sides is 600Mbps)
> i've tried to install rsync as a service on windows machine and use
> ssh as a tcp fordwarding and then the rsync speed is over 20MBps :-O
> Do you know what is the config problem for this slow speed with rsync
> directly over ssh?
> best regards

More information about the Cygwin mailing list