incorrect text mode graphic character display

Marco Atzeri
Sat May 9 21:32:40 GMT 2020

Am 09.05.2020 um 22:37 schrieb
> On Sat, 9 May 2020 08:32:17 +0200
> Marco Atzeri via Cygwin <> wrote:
>> Can you install a parallel Cygwin with only Base category ?
>> I use C:\cygwin64T for my parallel Cygwin installation.
>> This will help to check if a fresh version without any
>> user customization and minimal packages works.
> oh good grief. now things have become really weird.
> the problem i am having is with my work machine.  however i realized that i had not installed cygwin on my home machine, which is also W10.  i did that... and no problem, everything displays correctly !
> then i went back to my work machine and did a parallel installation as you recommended and that turned out to be a bit of a problem.
> I edited the path in the terminal icon to make sure it is running the mintty from the parallel installation, tried julia and ... it's still broken.
> however, being paranoid that i still wasn't running from the correct install directory i went and ran mintty directly from the parallel install directory and things were broken on start, it looks like the path was not set-up correctly. running 'ls' gives me a command not found error, and julia is trying to invoke stty and getting a command not found error.

the path is usually incorrect if you are not running a login shell
"mintty -" is the way to require mintty to run a login shell

> so i fixed PATH, that fixed those problems, ran julia, and still broken.
> BTW, this is how julia was trying to invoke stty:
>    stty raw -echo onlcr -ocrnl opost
> i thought that might be helpful.
> Unfortunately, because it's a work machine, i don't really feel comfortable posting the cygcheck output.  I tried to edit it, but there's just too much information that's specific to the directories and network that I would have to remove.
> given the results on my home machine i'm wondering if i should simply save off my home directory, kill both cygwin directories and start from scratch...

compare the cygcheck outputs of the two machines, may be it will give
an hint.
you can also compare the outputs of "set"

> Thanks for your continued help.

The only way I succeed to screw up the graphics is forcing
mintty to use a NOT UTF-8 like ISO-8859-1 in the "Text Options"

  x=DataFrame([(1,2,3), (4,5,6)])
2×3 DataFrame
│ Row │ 1     │ 2     │ 3     │
│     │ Int64 │ Int64 │ Int64 │
│ 1   │ 1     │ 2     │ 3     │
│ 2   │ 4     │ 5     │ 6     │

and probably does not like also a mismatch in locale
between bash and mintty.

I have not tested all the Terminal Type but it seems
that the usual xterm is working fine.


More information about the Cygwin mailing list