/dev/p* causes shell crash in i686

Andrew Schulman schulman.andrew@epa.gov
Wed Sep 9 12:08:44 GMT 2020

Here's a strange one. In bash in i686, try to run:

ls /dev/ptmx

I only get about as far as:

ls /dev/p

and then my terminal window vanishes. This happens:

* In fish or bash.
* On two different hosts that I've tried.
* In mintty or a system terminal. In the system terminal, sometimes the
command works normally the first time, but fails the 2nd time; or I have to
press <TAB> after `ls /dev/p`, then the terminal vanishes.
* With other commands that treat their arguments as files, not text. So for
example, I can't finish typing `cat /dev/ptmx` or `test -r /dev/ptmx`
before the terminal window vanishes, but `echo /dev/ptmx` works normally.

It doesn't happen:

* In x86_64 - only i686.
* In scripts - only interactively.

Is anyone else able to reproduce this? I've tried to capture an strace log,
but I've failed so far. The strace seems to stop the crash. Still trying.

I thought this could be a BLODA problem, but the two hosts I tried are
running different virus scanners (McAfee and Windows Defender).

Cygwin 3.1.7-1, all packages up-to-date. Output of cygcheck -svr attached.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck-svr.out
Type: application/octet-stream
Size: 177540 bytes
Desc: not available
URL: <https://cygwin.com/pipermail/cygwin/attachments/20200909/e552a0d0/attachment-0001.obj>

More information about the Cygwin mailing list