misterious GIT failure

matthew patton pattonme@yahoo.com
Fri Jan 8 02:13:47 GMT 2021


I've been using cygwin since like 20 years ago and do everything in it. A couple days ago my Git program mysteriously stopped working. I can see (GIT_TRACE=1) it invoke SSH and HTTPS connections just fine but it fails with a short-read/write when it's time for pack or unpack. Baffled I uninstalled Cygwin and blew away the Repo and started over. Git worked fine for a few hours and then BAM same problem. I've tried all three versions of git available in the repos. Short of deleting Cygwin entirely and starting over, nothing brings it back.

I use Github, Bitbucket, and CodeCommit (amazon) for various repositories and once Git stops working it won't work on any of them. (I briefly thought maybe there was some badly behaved backends)

Here's an example output. Anyone have a notion as to what the dickens is going on?

21:04:24.233957 git.c:444               trace: built-in: git fetch
21:04:24.238648 run-command.c:664       trace: run_command: unset GIT_PREFIX; GIT_PROTOCOL=version=2 ssh -o SendEnv=GIT_PROTOCOL git@github.com 'git-upload-pack '\''tb3088/shell-environment.git'\'''
remote: Enumerating objects: 34, done.
remote: Counting objects: 100% (34/34), done.
remote: Compressing objects: 100% (25/25), done.
21:04:25.119943 run-command.c:664       trace: run_command: git index-pack --stdin -v --fix-thin '--keep=fetch-pack 1011 on SOHO-GP4D633' --pack_header=2,1635
fatal: index-pack failed



More information about the Cygwin mailing list