gdb doesn't print the output on the terminal

Marco Atzeri marco.atzeri@gmail.com
Fri Jan 8 09:39:26 GMT 2021


On 08.01.2021 10:20, Gaetano Buldo via Cygwin wrote:
> Hello,
> I installed Cygwin for 64bit window, and the following tools in order to
> build and debug c programs using eclipse.
> gcc 9.3.0-2

why not the version 10 ?

> make 4.3-1
> gdb 9.2-1
> It seems like the gdb program doesn't print on the terminal.

this usually means you are missing some libraries or you have an 
incorrect version of oune of them

These commands can help to identify the issue

$ cygcheck /usr/bin/gdb

$ strace -o /tmp/gdb.strace /usr/bin/gdb --version


> When i run gdb --version a get an empty string on the terminal
> When i run gdb, i can see the programm running on the task manager, and i
> can quit it writing 'q' (even if the string doesn't appear on the terminal).
> gcc and make works fine. When i check the version i normally get the
> expected output, and i'm also capable to build a C project.
> Any suggestion?
> Thanks,
> Gaetano
> --

see also here
> Problem reports:      https://cygwin.com/problems.html

and provide the cygcheck.out as attachment

Regards
Marco



More information about the Cygwin mailing list