problem using gcc-core for compile qemu

Lee ler762@gmail.com
Fri Jan 8 22:32:33 GMT 2021


On 1/8/21, juan carlos rebate rodriguez via Cygwin  wrote:
>
> I think I expressed myself incorrectly or I am not able to be
> understood, no matter what package I choose. gcc-core does not compile
> using the cygwin dll, the one that compiles for that library is cygwin-
> gcc.
> now I will try to explain my case better,
> 1 when I use the gcc-core package if it is able to detect the whole
> set, the only thing that happens is that the script does not recognize
> cygwin nt as a valid operating system.
> 2 when I use the mingw64-x86_64-gcc package it is not able to compile
> without add-ons.
> for example when I compile with gcc-core if it is able to detect the
> libcaca-devel library, this is the library that qemu asks me for sd-
> card support,
> However, when I use the package mingw64-x86_64-gcc it is not able to
> find it in the system because it is not in its set,

If you use the mingw cross compiler you'll also need some cross compiler tools.
Take a look at
  https://cygwin.com/cgi-bin2/package-grep.cgi?grep=libcaca&arch=x86_64

You probably need to install
mingw64-x86_64-libcaca-0.99.beta19-1 - mingw64-x86_64-libcaca: Color
ASCII art library for Win64 toolchain

Regards,
Lee


More information about the Cygwin mailing list