gdb not working

Ken Brown kbrown@cornell.edu
Fri Jan 15 20:02:00 GMT 2021


On 1/15/2021 1:47 PM, Lemke, Michael SF/HZA-ZIC2 wrote:
> On Friday, January 15, 2021 4:45 PM Jon Turney wrote:
>> On 15/01/2021 12:28, Lemke, Michael wrote:
>>> I just installed a fresh copy of Cygwin and gdb with setup-x86_64.exe.
>>> However, gdb does not produce any output.
>>>
>>> Installing gdb versions 7.9.1-1 and 7.10.1-1 work, anything newer doesn't.
>>> Any ideas why?
>> [...]
>>
>>> Install gdb 7.12.1-2
>>>    pc> gdb -v
>>> Install gdb 8.0.1-1
>>>    pc> gdb -v
>>>    pc> cygcheck -c gdb
>>> Cygwin Package Information
>>> Package              Version        Status
>>> gdb                  8.0.1-1        OK
>>
>> You might try 'strace gdb' and see if that sheds any light on what's
>> failing.
> 
> I tried that but I couldn't see anything strange.

No error code?  Please show the output.

> Also ldd `which gdb` is
> fine.

Please show the output.

> I tried the cygcheck Marco Atzeri suggested. I am not comfortable to send
> the result to the list but I checked it.

Can you remove the sensitive parts and then send it?  It's hard for anyone on 
the list to help you if you don't provide information about your installation.

> As a result I cleaned up my path to just /bin which removed some duplicate
> entries in cygcheck.out but gdb still doesn't work.
> 
> The only strange part I see in cygcheck.out is a slight mess up with my
> installation, a result of my moving /c/cygwin64 to /c/mystuff/ncygwin64
> after my first run of setup.exe, see below.  So what has changed between
> gdb 7.10.1-1 and gdb 7.12.1-2?

Dependencies may have changed.  Have you checked that you have all dependencies 
of whatever version you're trying to run?  Just re-running setup should take 
care of that if that's the problem.

Ken


More information about the Cygwin mailing list