pylint: ImportError: No module named pkg_resources

Marco Atzeri
Sun Jan 17 05:32:44 GMT 2021

On 17.01.2021 00:18, Oleksandr Gavenko via Cygwin wrote:
> After installing pylint:
>    setup.exe -p pylint
> I expected I can use the package:
>    pylint /dev/null
>    Traceback (most recent call last):
>      File "/usr/bin/pylint", line 5, in <module>
>        from pkg_resources import load_entry_point
>    ImportError: No module named pkg_resources
> I tried to add package:
>    python-setuptools
> as suggested by:
> and now it works.

Noted. I will look on it as it was anyway built for python2
that is now EOL

So need to be rebuilt to work with python3

> I believe that x86_64/setup.bz2 is broken:
>    depends2: python, python-logilab-astng, python-logilab-common
> It doesn't mention python-setuptools.
> Or it might be that /usr/bin/pylint should be rewritten to avoid dependency to
> setuptools.

This explain the status problem:

  $ grep -e "pylint" -e "logilab" cygwin-pkg-maint
pylint                                       ORPHANED (Jari Aalto)
python-logilab-astng                         ORPHANED (Jari Aalto)
python-logilab-common                        ORPHANED (Jari Aalto)

I guess one is also dead upstream (or was totally re-shaffled)
but I need to look again .

Thanks for the report

More information about the Cygwin mailing list