LyX becomes unresponsive to mouse

Chris Marshall
Sat Jan 30 19:53:29 GMT 2021


Yesterday I started some documentation work using my favorite LyX cygwin 

> CYGWIN_NT-10.0 mypc 3.1.7(0.340/5/3) 2020-08-22 17:48 x86_64 Cygwin


>  lyx --version
> LyX 2.3.5-1 (2020-06-02)
> Configuration
>   Host type:               x86_64-pc-cygwin
>   Special build flags:      build=release std-regex use-hunspell 
> use-aspell use-enchant
>   Bundled libraries:        boost mythes
>   C++ Compiler:            g++ (9.3.0)
>   C++ Compiler flags:       -O2 -std=c++14
>   C++ Compiler user flags:   -std=c++14  -ggdb -O2 -pipe -Wall 
> -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 
> -fstack-protector-strong --param=ssp-buffer-size=4 
> -fdebug-prefix-map=/pub/devel/lyx/lyx- 
> -fdebug-prefix-map=/pub/devel/lyx/lyx-
>   Linker flags:
>   Linker user flags:
>   Qt Frontend:
>       Qt version:          5.9.4
>   Packaging:               posix
>   LyX binary dir:          /usr/bin
>   LyX files dir:           /usr/share/lyx

After about 5 minutes, the LyX window and frame became completely 
unresponsive to mouse interaction.  I could resize the window but the 
contents did not resize/rearrange to fit the change in window shape.

Doing "kill -9 PID-of-lyx" had no effect but if I killed the PPID-of-lyx 
then the lyx window would close.

I tried running LyX with "strace lyx" which was slow on starting from 
all the terminal output and then the window opened but the expected 
contents were never displayed.  It appears that the "hang" happened 
before the strace lyx could complete its initialization.

Again, "kill -9 PID-of-lyx" had no effect but it worked if I killed the 
PPID-of-lyx (i.e. strace and not bash this time).

I tried uninstalling and reinstalling  the previous cygwin release 
version and even the latest cygports version.  All showed the same problem.

It may be useful that I had not had this problem previously with lyx on 
windows 10 with cygwin.  I don't know those version numbers but it was 
before the move to Qt5 which I saw some discussion regarding LyX.

Has anyone seen this problem and/or have an idea for a fix?  It seems 
not to be specific to the recent LyX version number but I am not able to 
try earlier than the cygwin release.

At the moment, I am stuck without LyX under cygwin.  I plan to try the 
native LyX for windows to see if I can get LyX running for the near term.


More information about the Cygwin mailing list