Sv: Problems with native Unix domain sockets on Win 10/2019

sten.kristian.ivarsson@gmail.com sten.kristian.ivarsson@gmail.com
Tue Mar 16 11:06:17 GMT 2021


Hi all

Does anyone know the status of these fixes ?

I saw an announcement for cygwin-3.2.0-0.1 that seemed to contain some
AF_UNIX-related fixes but I fail to find out where that distribution exists
(if it is supposed to be publicly accessible?), but I tried out the
2021-03-01 snapshot and perhaps they are similar ?

We bumped into some AF_UNIX-related issues when trying the 2021-03-01
-snapshot though. It might be some flaws in our code base but the same code
works in quite a few Linux-distros

We're more than willing to help out with testing this and/or trying to
narrow down any possible cygwin issues, but first we'd be glad if someone
could give us some kind of status report of this (so no one is doing any
unnecessary work)


Best regards,
Kristian

p.s.
   I tried to build the topic/af_unix -branch according to the FAQ, but
there was some issues
d.s.



> > Hi Ken, Corinna
> >
> > Sorry for the delay in responding. I have just tested the fix and it
> > works great. Thank you very much for looking into it.
> >
> > When do you think it would be available in a form that regular users
> > would be able to update/install?
> 
> Corinna decides when to make a new Cygwin release.  My best guess is
> "pretty soon".
> 
> > Also, one observation FYI, is that the "ls -l" command on Unix
> > normally indicates sockets with an "s" as the first character of the
> > output: eg
> >
> > srwxr-xr-x  1 Michael None         0 Feb  7 11:19 foo.sock
> >
> > Currently, what is shown on Cygwin is
> >
> > -rwxr-xr-x  1 Michael None         0 Feb  7 11:19 foo.sock
> >
> > indicating a regular file.
> 
> Right.  From Cygwin's point of view, it is a regular file.  There might
> come a time when Cygwin's AF_UNIX implementation makes use of native
> Windows AF_UNIX sockets on systems that support them.  But that time is
> not currently in sight.
> 
> Ken
> --
> Problem reports:      https://cygwin.com/problems.html
> FAQ:                  https://cygwin.com/faq/
> Documentation:        https://cygwin.com/docs.html
> Unsubscribe info:     https://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list