Error running gitg

Keith Thompson Keith.S.Thompson@gmail.com
Sun Mar 21 21:21:37 GMT 2021


I just installed the gitg package, version 3.26.0-1.

When I run it, I get the following error, and the GUI doesn't launch:

** (gitg:8004): WARNING **: gitg-plugins-engine.vala:40: Could not
load repository: Typelib file for namespace 'Peas', version '1.0' not
found

** (gitg:8004): WARNING **: Error retrieving accessibility bus
address: org.freedesktop.DBus.Error.NoReply: Message recipient
disconnected from message bus without replying

(gitg:8004): GLib-GIO-ERROR **: Settings schema
'org.gnome.gitg.state.window' is not installed

A Google search for the error message turns up a similar problem on
Arch Linux, reported in 2011. Yes, that's 10 years ago, but it might
provide a clue.

https://bugs.archlinux.org/task/23029
"""
When launching gitg from a terminal, a "Settings schema
'org.gnome.gitg.state.window' is not installed" error is displayed.

By adding the following line to the post_install and post_remove hooks
of gitg.install file the problem seems to be solved:
usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas
"""


More information about the Cygwin mailing list