cygwin-3.1.0 and mintty from desktop shortcut

Achim Gratz
Mon Mar 22 20:13:42 GMT 2021

ASSI writes:
> Takashi Yano via Cygwin writes:
>>> 1. Rename /usr/share/locale to something else, like local.bak.
>>> 2. Start mintty in the usual way.
>>> 3. Rename the directory from step 1 back to /usr/share/local.
>>> 4. Work just like the problem never existed either in the shell running
>>> inside the mintty or even start a new mintty.
>> I guess renaming /usr/share/locale/locale.alias is enough.
> I've had some time to look into this problem again after having updated
> Cygwin to the latest and greatest.  Indeed, when
> /usr/share/locale/locale.alias
> gets renamed, the problem also goes away.  This is great because I don't
> really need the locale aliases for anything.  Btw, my laptop got
> upgraded to Win10 1909 (Enterprise) in the meantime, so the issue isn't
> specific to 1803 as was supected earlier.
> I then tried to figure out what exactly causes the problem and it turns
> out that it's the _presence_ of this file with the additional condition
> that it must not be owned by the user starting the mintty/shell.  Since
> I install Cygwin on my work laptop with a different (admin) account and
> not my (non-admin) user account, that explains why I am seeing the
> problem there and not on other machines.  Before you are going to
> suggest that it's the admin vs. non-admin rights: no, if I create a
> locale.alias with my user account (either as an empty file or a copy of
> the backup file), then the admin account is unable to start a shell in
> mintty successfully.  I have no idea why the ownership of a file that
> only should get read (and is readable by everyone) would have the
> effect I'm seeing, but maybe that gives the clue on where to look for a
> fix.

With the 3.1.2 test version of Cygwin these errors no longer occur (as
well as a few others that I worked around with CYGWIN=disable_pcon as an
intermediate measure).

+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

SD adaptations for Waldorf Q V3.00R3 and Q+ V3.54R2:

More information about the Cygwin mailing list