Typed characters are mis-ordered when CPU usage is high

Orgad Shaneh orgads@gmail.com
Thu Mar 17 18:40:15 GMT 2022


On Fri, Mar 11, 2022 at 11:36 PM Takashi Yano <takashi.yano@nifty.ne.jp> wrote:
> I looked into this problem and found the cause.
> This seems to be due to a bug of fsync(). Cygwin's fsync()
> flushes the console input buffer unlike linux.
>
> I will propose a patch for this issue.
>
> --
> Takashi Yano <takashi.yano@nifty.ne.jp>

Thank you very much. Looks better now.

I'm sorry for nudging, but on msys2 I still get frequent mistypes when
typing fast.

I (still) don't have a consistent reproduction, but if I get it
correctly, it looks like one or more characters I type right when the
prompt appears show up before the buffered characters.

For instance, I run git fetch, and while it is running I type git
status, *sometimes* 1-2 characters "pop" to the left, so I get
something like tgit satus.

I wasn't able to reproduce it with cygwin, but on msys2 (with cygwin
3.3 branch merged in) it happens to me all the time :/

- Orgad


More information about the Cygwin mailing list