Nano fails to open file "~/.bashrc".

Kirill Frolov
Fri Mar 3 12:52:50 GMT 2023

I run it with F:\cygwin64\bin\mintty.exe -i /Cygwin-Terminal.ico -

$ getent passwd "$USER"; mount; cat /etc/nsswitch.conf
F:/cygwin64/bin on /usr/bin type ntfs (binary,auto)
F:/cygwin64/lib on /usr/lib type ntfs (binary,auto)
F:/cygwin64 on / type ntfs (binary,auto)
C: on /cygdrive/c type ntfs (binary,posix=0,user,noumount,auto)
D: on /cygdrive/d type ntfs (binary,posix=0,user,noumount,auto)
E: on /cygdrive/e type ntfs (binary,posix=0,user,noumount,auto)
F: on /cygdrive/f type ntfs (binary,posix=0,user,noumount,auto)
# /etc/nsswitch.conf
#    This file is read once by the first process in a Cygwin process tree.
#    To pick up changes, restart all Cygwin processes.  For a description
#    see
# Defaults:
# passwd:   files db
# group:    files db
# db_enum:  cache builtin
# db_home:  /home/%U
# db_shell: /bin/bash
# db_gecos: <empty>

On 03.03.2023 15:47, Andrey Repin wrote:
> Greetings, Kirill Frolov!
>> When i run nano ~/.bashrc nano opens with   [ Directory '/home/frolo' does not exist ] error.
> Do you run it from bash prompt or from CMD prompt?
>> The file opens with cat ~/.bashrc
> Can you please show us the output of
> getent passwd "$USER"; mount; cat /etc/nsswitch.conf

More information about the Cygwin mailing list