[ITP] amanda 3.3.2

marco atzeri marco.atzeri@gmail.com
Thu Sep 6 12:34:00 GMT 2012

On 9/6/2012 2:17 PM, Mark O'Keefe wrote:
> Version of amanda for cygwin.
> Available for gentoo:  http://packages.gentoo.org/package/app-backup/amanda
> Available for debian:  http://packages.debian.org/squeeze/amanda-server
> The version 3.3.2 is the latest stable version.
> sdesc: "AMANDA Network Backup program"
> ldesc: "AMANDA, the Advanced Maryland Automatic Network Disk Archiver,
> is a backup solution that allows the IT administrator to set up a single
> master backup server to back up multiple hosts over network to tape
> drives/changers or disks or optical media. Amanda uses native utilities
> and formats (e.g. dump and/or GNU tar) and can back up a large number of
> servers and workstations running multiple versions of Linux or Unix.
> Amanda uses a native Windows client to back up Microsoft Windows desktops
> and servers."
> category: Archive
> requires: bash bzip2 gzip xz tar perl libffi4 libgcc1 libglib2.0_0 libiconv2 libint18 libncursesw10 libpcre1 libreadline7 libssp0 cygwin
> wget \
> 	http://my-cygwin-amanda.googlecode.com/files/setup.hint \
> 	http://my-cygwin-amanda.googlecode.com/files/amanda-3.3.2-4.tar.bz2 \
> 	http://my-cygwin-amanda.googlecode.com/files/amanda-3.3.2-4-src.tar.bz2
> NOTE:  The current version of tar (1.25) available from cygwin is broken and doesn't work for amanda :-(  I've created a patch for the 1.26 version of tar to create a working amanda installation on my machine.  Not sure how to get the current maintainer to update the official version to 1.26.
> The packages is currently setup as server and client together.  I haven't tried splitting it into parts like debian does.
> On 06/09/2012, at 9:24 PM, Mark O'Keefe wrote:
>> Thanks Marco.
>> I had subscribed to this list and attempted to post an ITP there, however I have received no answer and the posts don't go through.  I've also tried the list owner to no avail.
>> Thanks for the comment on category.  I will fix that.  I changed it as a suggestion thinking to ask about it.
>> Cheers,
>> Mark.

I tested your previous version

I see a install failure

make[5]: Entering directory `/pub/prove/amanda-3.3.2-4/build/common-src'
Setting installation permissions on executables
chown root:root /pub/prove/amanda-3.3.2-4/inst/usr/sbin/amservice
chown: invalid user: `root:root'
Makefile:2292: recipe for target `installperms-exec' failed

probably not relevant, but I am not sure everthing is installed

$ cygport amanda-3.3.2-4.cygport list

this is in the wrong place
and also the name is unusual


More information about the Cygwin-apps mailing list