Mysterious FTP failure

Brian Kelly
Thu Dec 19 06:43:00 GMT 2002

I’ve been using cygwin’s ftp.exe client program on my NT 4.0 SP 6
machine for quite a while. It’s
worked flawlessly for months. I have not made any changes to the box and
have not upgraded any
cygwin components in months. Sometime in the last 48 hours “something”
changed. Now when
I attempt to ftp a tar file, it sends about 98-99% of it or so, and then
mysteriously quits – “thinking”
it had sent the whole thing. (It does not report any transmission
errors). It’s not tar, because if I
ftp TO the box via inetd/ftpd and retrieve the file – the whole thing
transfers just fine. I’ve rebooted the
box numerous times, as well cold shutdown (to reset the network card) –
same problem. I haven’t
tried uninstalling or reinstalling any cygwin components, because I’d
really like to understand what’s
CAUSING the problem. I’m writing automation software that has advanced
error checking and I’d
like to trap and “identify” this condition (if possible) and advise in
an error message what the possible
genesis of the condition is and what hints one can follow to remedy
and/or prevent the problem. The
automation software essentially “automates” cross-network unix
command-line environments and is
100% perl. As such, it relies on cygwin for this environment on MSWin
boxes. If one “node” fails – it
can switch boxes automatically – but being able to determine WHY a box
has a problem and reporting
it successfully is VERY important to the overall approach of the
If anyone’s got a clue what’s happened to break ftp – or can suggest
what other things I can investigate
to get the “bottom” of this problem – I’d REALLY appreciate it.
Brian Kelly

Unsubscribe info:
Bug reporting:

More information about the Cygwin mailing list