Can't start cron daemon in Cygwin 1.5.23 under WinXP SP2

Steve Rowley
Thu Jan 25 19:47:00 GMT 2007

>Date: Thu, 25 Jan 2007 19:17:52 +0000
>From: "Dave Korn" <>
>On 25 January 2007 18:03, Steve Rowley wrote:
>>   >[...]
>>   >mkgroup_l_d:S-1-5-32-545:10545:
>     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>  You are in a domain and you didn't use the -d option, hence the following
>output in your cygcheck:
>> 10545(mkgroup_l_d)
>  This could perhaps lead to cygwin getting confused about permissions.

Ok, I just tried mkgroup -lcd, but that included many lines of
irrelevant cruft from the corporate domain.  So I just removed the
mkgroup_l_d line from /etc/group; is that what you recommend?

That, alas, did not fix the problem.  Running cron-config still
produced the following when it tried to start cron as a service:

  >Do you want to start the cron daemon as a service now? (yes/no) yes
  >cygrunsrv: Error starting a service: QueryServiceStatus:  Win32 error 1053:
  >The service did not respond to the start or control request in a timely fashion.

>> I have Symantec AntiVirus, but none of the others you mention.
>> Symantec AntiVirus I can't mess with, since it's installed in a
>> nonmodifiable way by an IT department.
>  Does it have any "anti-spyware" or "suspicious behaviour blocking"
>  features?

Beats me; possibly.  In any case, all of its settings are locked down
and not changeable by me.  Is this specifically known to be a problem?

>> However, since you suggested it, I checked the Symantec logs and it
>> hasn't fired on anything for several weeks, which is how old this
>> computer is.  So it seems unlikely to be Symantec, no?
>  Doesn't prove anything; it can easily mess up cygwin without thinking cygwin
>is a virus, it's just that the checking mechanisms are so crude and disruptive
>they can easily break applications.

Still, I'd think it would log _something_.  But that's just my guess,
and unlogged weird interactions are of course both possible and common.

>> However, see previous reply to Pierre in which it turned out that
>> Microsoft's Windows Defender was strangling cygrunsrv.  That was a
>> definite problem, but when I uninstalled Windows Defender the
>> underlying problem still remained.  Definitely looks to me like
>> something is preventing cygrunsrv from forking a process...
>  Symantec could /also/ be causing it.  Also, I notice you didn't mention any
>firewall at all?

Good point.  There's a software firewall, also not modifiable by me,
called Proventia Desktop.  It's been logging an interesting number of
UDP probes, but nothing cron related.  One more bit of evidence: I can
(temporarily) turn it off, and doing so does not fix my cron problem.
Steve Rowley <> Skype: sgr000
It is very dark & after 2000.  If you continue, you are likely to be eaten by a bleen.

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list