trouble with bash / if in recent release / update ?

Tim Hanson t.hanson@faz.de
Mon Jan 29 18:19:00 GMT 2007


hi, a colleague and i recently tried upgrading an existing cygwin and found that
basic bash script features broke. he later went back to a working copy, tested
and discovered that the features worked, upgraded again and confirmed that they
were broken again. i've searched for hints that others have had this problem and
haven't found any. the symptoms are pretty easy to test.

in an interactive bash shell one can conform that these two if statements work:

  if [[ -z "17" ]]; then  echo "ja"; else   echo "ne"; fi
  ne

  if [[ -z "" ]]; then  echo "ja"; else   echo "ne"; fi
  ja

if one then builds a bash script consisting only of #!/usr/bin/bash
and this if statement (broken into separate lines) it fails along these lines:

	$ test.bash
	: command not test.bash: line 9:
	/usr/local/bin/test.bash: line 10: syntax error in conditional expression
	'usr/local/bin/test.bash: line 10: syntax error near `]]
	'usr/local/bin/test.bash: line 10: `if [[ -z "$1" ]]

does this ring a bell for anyone?

i'd be grateful for pointers. (or advice on how to provide more clues.)

cheers,

Tim


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list