Newly-installed bash 3.2.9-10 (cygwin 1.5.24-1) exits when I try to execute a program

Glenn Serre gaserre@spiresoftware.com
Tue Jan 30 07:17:00 GMT 2007


Good evening,

jm.challier@free.fr wrote:
> Good morning.
> 
> I'm quite happy to find this thread - I thought I was the one who messed things
> up... ;^)
> 
> I experience exactly the same problem : XP64, recently updated cygwin -> bash
> exits with code 128 when trying to execute anything (except builtins, of
> course). Same thing for gcc (tried from emacs too).
> 
> To answer a question that was asked in the "xp64 fails with latest download"
> thread (which deals with the same problem) : I have only one cygwin1.dll file on
> the system.
> 
>> Reverting to cygwin 1.5.23 worked.
>> Is someone working to fix this, or is this an opportunity for me to submit a
> patch?
> 
> If you have a patch working, pease go ahead. Reverting to 1.5.23 is not a patch,
> but a workaround :-) Meanwhile, I'll stick with my good'ol'32-bit laptop...

I have no working patch, I was going to use this problem as an opportunity for 
my first attempt to build and debug the cygwin DLL (while maybe even charging a 
client for it) but it looked to me as if it may already be being addressed. 
Looking again, I see that this might not be that case, so I'll see what I can do 
(no promises, as I'm a newbie at cygwin development).

> 
> By the way, in case it's a version consistency problem, what mirror are you
> using ? I'm using ftp://mirror.cict.fr/ - nearest from home.
[...]

http://cygwin.elite-systems.org.

--Glenn S.


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list