trouble with bash / if in recent release / update ?

Daniel Brockman dan@spicetrader.net
Tue Jan 30 07:18:00 GMT 2007



Tim Hanson <t.hanson <at> faz.de> writes:

> 
> hi, a colleague and i recently tried upgrading an existing cygwin and found 
that
> basic bash script features broke. 
> [...]
> 
> does this ring a bell for anyone?
> 
> i'd be grateful for pointers. (or advice on how to provide more clues.)
> 
> cheers,
> 
> Tim
> 
> 
You aren't alone, Tim.

I have same problem. I updated last night. My sh (bourne shell) scripts didn't 
work this morning. I diff the bash.exe and sh.exe binaries and they are the 
same. I tried updating from a differnt mirror, but that didn't fix the problem.

Workaround: I'm using zsh instead of sh .

Back to the bugs ... `echo' command seems to work backwards! 
In a script...

  echo foo bar

produces output ...

  bar foo

A blank line in the script file produces err msg 

: command not found

I can't figure out a way to make the new version of sh.exe work. Imho, it's 
broken.



db





--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list