native emacs and manual page

Wed Dec 31 07:08:00 GMT 2008

I run a native windows build of gnu emacs (downloaded binary distribution
from on my vista box.  I can
launch emacs either from a windows terminal (cmd.exe), or from a cygwin bash
shell.  I run native emacs instead of cygwin emacs so that I can get the
emacs gui without installing cygwin/X (nothing wrong with cygwin/X, I am
just a minimalist type).

Everything works fine with this set up except one: I cannot view manual
pages in emacs.  Instead of viewing man pages in cygwin terminal, I like to
do it in emacs using "M-x man".  But it wouldn't work with my setup, which
is expected because the native emacs build probably doesn't know about
cygwin.  Here is what I observe:

1 If I start emacs from cmd.exe, then hit say, M-x man ls, I get an error
message in the minibuffer saying "error in process sentinel: *Man ls*:
process exited abnormally with code 255

2 If I start emacs from cygwin bash shell, I get a popup window stating
"c:\Program Files\GNU\emacs-22.3\bin\cmdproxy.exe the NTVDM CPU has
encoutered an illegal instruction. ...  Choose 'Close' to terminate the

I am hoping someone knowledgeable on this list could give me a hint as how
to resolve either or both of the problems?   Perhaps there is some magic
configuration that makes emacs invoke the correct (cygwin) command? 


View this message in context:
Sent from the Cygwin list mailing list archive at

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list