scp just spews usage

Brian Wilson
Sat Nov 27 15:14:00 GMT 2010

> > Hi,
> > I've been using ssh with cygwin for years w/ no issues.? After my last
> > upgrade, I am not able to use scp (ssh still works).
> > 
> > $ scp myfile myusername@myserver:~
> > usage: scp [-1246BCpqrv] [-c cipher] [-F ssh_config] [-i identity_file]
> >            [-l limit] [-o ssh_option] [-P port] [-S program]
> >            [[user@]host1:]file1 ... [[user@]host2:]file2
> > 
> > This same command has worked for me for long time.? Any ideas what's
> > happening now?? (I have tried rebooting since the upgrade).
> >
> I noticed that when I upgraded and didn't mind the messages from the
> setup-program saying that cygwin1.dll was in use and couldn't be
> updated.
> Try updating again and/or reinstalling ssh and be careful of the
> messages.

I had a similar issue.  It seems that some updates do not complete successfully under the circumstances you describe.  I 
suspect there is an issue with shells failing to run successfully as I often have to try several times before I can get 
Cygwin to open a bash shell successfully.  Others require a reboot (and you need to watch the messages for this 

I found I could fix most problems by booting to safe with networking mode and reinstalling the packages that weren't 
working.  This restored my applications.  I hope this works for you as well.  I do the safe mode to prevent any problems 
with deamons or other applications running in the background.


Brian S. Wilson

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list