autorebase.bat stalls during setup-x86.exe

Corinna Vinschen
Fri Aug 23 18:56:00 GMT 2013

On Aug 23 18:39, Fritz, Jason wrote:
> Hi Corinna,
> My environment seems to have been seriously damaged by the upgrade.  I started a bash (not dash) shell and immediately saw these errors:
> -bash: id: command not found
> -bash: id: command not found
> -bash: cut: command not found
> I tried running 'ls' and also got "command not found".  My Cygwin/bin dir is missing ls.exe.
> I tried running 'rebaseall' but got strange errors:
> jfritz@JFRITZ-W7 ~
> $ /usr/bin/rebaseall
> -bash: /usr/bin/rebaseall: /bin/ash: bad interpreter: Permission denied

Don't run rebaseall from bash.  Running it from ash/dash is advisable
to make sure no process blocks a DLL.

> Running "cygcheck -c" shows lots of incomplete packages (output below).
> BTW, I wasn't clear in my last email.  The 7 min stall ended when I cancelled the installer because the autorebase.bat was stuck again.
> I guess I'll reinstall.  Thank you for your help.

Yeah, that sounds best.  I'm sorry what happened to your installation
but it's kind of hard to see what caused it.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: not available
URL: <>

More information about the Cygwin mailing list