autorebase.bat stalls during setup-x86.exe

Fritz, Jason
Fri Aug 23 18:40:00 GMT 2013

Hi Corinna,

My environment seems to have been seriously damaged by the upgrade.  I started a bash (not dash) shell and immediately saw these errors:

-bash: id: command not found
-bash: id: command not found
-bash: cut: command not found

I tried running 'ls' and also got "command not found".  My Cygwin/bin dir is missing ls.exe.

I tried running 'rebaseall' but got strange errors:

jfritz@JFRITZ-W7 ~
$ /usr/bin/rebaseall
-bash: /usr/bin/rebaseall: /bin/ash: bad interpreter: Permission denied

Running "cygcheck -c" shows lots of incomplete packages (output below).

BTW, I wasn't clear in my last email.  The 7 min stall ended when I cancelled the installer because the autorebase.bat was stuck again.

I guess I'll reinstall.  Thank you for your help.
- Jason

$ cygcheck -c
Cygwin Package Information
Package              Version              Status
_autorebase          000393-1             OK
_update-info-dir     01180-1              OK
alternatives         1.3.30c-10           OK
base-cygwin          3.3-1                OK
base-files           4.1-1                OK
bash                 4.1.10-4             Incomplete
bison                2.7.1-1              OK
bzip2                1.0.6-2              Incomplete
coreutils            8.15-1               Incomplete
crypt                1.2-1                OK
csih                 0.9.7-1              OK
cygrunsrv            1.40-2               OK
cygutils             1.4.14-1             OK
cygwin               1.7.24-1             OK
cygwin-doc           1.7-1                OK
dash                 0.5.7-1              Incomplete
diffutils            3.2-1                Incomplete
dos2unix             6.0.3-1              OK
dri-drivers          8.0.5-1              OK
editrights           1.01-2               OK
file                 5.11-1               Incomplete
findutils            4.5.11-1             Incomplete
flex                 2.5.35-1             OK
font-adobe-dpi75     1.0.2-1              OK
font-alias           1.0.3-1              OK
font-encodings       1.0.4-1              OK
font-misc-misc       1.1.1-1              OK
fontconfig           2.10.93-1            OK
gawk                 4.1.0-1              OK
gettext               Incomplete
grep                 2.6.3-1              Incomplete
groff                1.21-2               Incomplete
gzip                 1.4-1                Incomplete
inetutils            1.7-2                Incomplete
ipc-utils            1.0-1                OK
less                 444-1                Incomplete
libasn1_8            1.5.2-4              OK
libattr1             2.4.46-1             OK
libblkid1            2.21.2-1             OK
libbz2_1             1.0.6-2              OK
libcom_err2          1.42.7-1             OK
libdb4.5              OK
libedit0             20120311-1           OK
libexpat1            2.1.0-3              OK
libffi4              4.5.3-3              OK
libfontconfig1       2.10.93-1            OK
libfontenc1          1.1.2-1              OK
libfreetype6         2.4.12-1             OK
libgcc1              4.7.3-1              OK
libgdbm4             1.8.3-20             OK
libglapi0            8.0.5-1              OK
libgmp10             5.1.2-1              OK
libgmp3              4.3.2-1              OK
libgssapi3           1.5.2-4              OK
libheimbase1         1.5.2-4              OK
libheimntlm0         1.5.2-4              OK
libhx509_5           1.5.2-4              OK
libICE6              1.0.8-1              OK
libiconv2            1.14-2               OK
libintl8              OK
libkafs0             1.5.2-4              OK
libkrb5_26           1.5.2-4              OK
libllvm3.1           3.1-3                OK
liblzma5             5.0.2_20110517-1     OK
libmpfr4             3.1.2-1              OK
libncurses10         5.7-18               OK
libncursesw10        5.7-18               OK
libopenssl100        1.0.1e-2             OK
libpcre0             8.21-2               OK
libpixman1_0         0.30.2-1             OK
libpopt0             1.6.4-4              OK
libreadline7         6.1.2-3              OK
libroken18           1.5.2-4              OK
libsigsegv2          2.10-1               OK
libSM6               1.2.1-1              OK
libsqlite3_0         3.7.17-3             OK
libssp0              4.7.3-1              OK
libstdc++6           4.7.3-1              OK
libuuid1             2.21.2-1             OK
libwind0             1.5.2-4              OK
libwrap0             7.6-21               OK
libX11-xcb1          1.6.0-1              OK
libX11_6             1.6.0-1              OK
libXau6              1.0.8-1              OK
libXaw7              1.0.11-1             OK
libxcb-icccm4        0.3.9-1              OK
libxcb-image0        0.3.9-1              OK
libxcb-shm0          1.9.1-2              OK
libxcb-util1         0.3.9-1              OK
libxcb1              1.9.1-2              OK
libXdmcp6            1.1.1-1              OK
libXext6             1.3.2-1              OK
libXfixes3           5.0.1-1              OK
libXft2              2.3.1-1              OK
libxkbfile1          1.0.8-1              OK
libxml2              2.9.1-1              OK
libXmu6              1.1.1-1              OK
libXmuu1             1.1.1-1              OK
libXpm4              3.5.10-1             OK
libXrender1          0.9.8-1              OK
libXt6               1.1.4-1              OK
login                1.10-10              OK
luit                 20121014-1           OK
m4                   1.4.16-1             Incomplete
man                  1.6g-2               OK
mintty               1.1.3-1              OK
mkfontdir            1.0.7-1              OK
mkfontscale          1.1.1-1              OK
openssh              6.2p2-1              OK
perl                 5.14.2-3             OK
perl_vendor          5.14.2-3             OK
rebase               4.4.0-1              Incomplete
run                  1.3.0-1              OK
sed                  4.2.2-3              OK
tar                  1.26-1               OK
terminfo             5.7_20091114-14      OK
texinfo              4.13-4               Incomplete
tzcode               2013c-1              OK
util-linux           2.21.2-1             OK
vim-minimal          7.3.1152-1           OK
which                2.20-2               OK
X-start-menu-icons   1.0.4-1              OK
xauth                1.0.7-1              OK
xcursor-themes       1.0.4-1              OK
xf86-video-dummy     0.3.6-2              OK
xf86-video-nested    0.1.0-3              OK
xinit                1.3.2-1              Incomplete
xkbcomp              1.2.4-1              OK
xkeyboard-config     2.9-1                OK
xmodmap              1.0.7-1              Incomplete
xorg-docs            1.7-1                OK
xorg-server          1.14.2-1             OK
xorg-server-common   1.14.2-1             OK
xrdb                 1.0.9-1              Incomplete
xterm                291-1                OK
xz                   5.0.2_20110517-1     Incomplete
zlib0                1.2.8-1              OK

-----Original Message-----

On Aug 23 16:26, Fritz, Jason wrote:
> Thanks Corinna, I suppose I'll try to reinstall.  Is there an easy way 
> to see a list of packages I've installed on top of the default 
> install, so that I can install all those same packages?

Uh, no, there's no such functionality, but you can call `cygcheck -c'
to see the list of all installed packages.

> FYI, each time I run setup-x86.exe I get the same behavior.  Here is a 
> snippet of a follow-on session from setup.log (notice the 7 min stall 
> at autorebase.bat):

I'm not sure why it should take seven minutes, but it can take a lot of time of you installed a lot of DLLs.  It's nothing to worry about, as long as it works.

Can you try what happens if you stop all Cygwin processes, start a lone dash.exe and enter "/usr/bin/rebaseall" on the command line?
Does it run and silently exits, or do you see any kind of error message?


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat

More information about the Cygwin mailing list