The procedure entry point could not be located in cygwin1.dll

Ken Brown
Fri Sep 23 22:35:00 GMT 2016

On 9/23/2016 4:50 PM, William Forsyth wrote:
> I broke my win XP cygwin install such that bash fails to start.
> I used Setup.exe version 2.870.
> The install failed when trying to run the postinstall bash scripts.
> After the install failure bash fails every time with:
> The procedure entry point __locale_ctype_ptr could not be located in
> the dynamic link library cygwin1.dll.
> The install failed because it tried to install cygwin 2.6.0 which is
> not compatible with winxp.
> I reran Setup.exe to grab cygwin version 2.5.2-1 but the install still
> fails with the same cygwin1.dll error.
> Already tried to grab cygwin version 2.5.0 (which is the last known
> good cygwin version that ran on my machine) from the time machine, but
> I keep getting the same cygwin1.dll error.  Any ideas how to fix this.

You probably have a version of bash that was built for cygwin-2.6.0. 
Try reverting bash to whatever release was current just before 
cygwin-2.6.0 was released.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list