Automatic Drive Mapping

Chris Faylor
Wed Jun 21 08:05:00 GMT 2000

On Wed, Jun 21, 2000 at 08:42:22AM -0400, Jason Tishler wrote:
>Jason Tishler wrote:
>> When I first tried this (about a month ago), I seemed to have problems
>> with Sun's javac and/or Microsoft's cl complaining about UNC paths not
>> being supported for the the current directory.  When I tried to reproduce
>> the problem today, I can only get cmd to fail.  But, who cares about cmd
>> anyway?
>It appears after more head scratching (not banging), I am able to
>reproduce the problem that Sun's javac cannot deal with UNC style
>    $ mount
>    Device              Directory           Type         Flags
>    K:\jdk1.2.2         /usr/java           system       binmode
>    ...
>    $ javac 
>    $
>    $ umount -s /usr/java
>    $ mount -s -b //cancerman/apps/jdk1.2.2 /usr/java
>    $ javac 
>    java.lang.Error: Fatal: Resource for javac is missing
>	    at
>    ...
>The point of the above is to demonstrate that there is at least one
>important (IMO) native Win32 app that cannot deal with UNC style paths.

I don't understand why mounting and umounting will have any effect on
a non-cygwin application.

Also, if javac is not reacting correctly to UNC paths then have you
reported this as a bug to Sun?


More information about the Cygwin-developers mailing list