Error running cygcheck.

Yllman, Jens
Wed Dec 5 04:17:00 GMT 2001


 I tried to run cygcheck. But I get 'cygcheck: dump_sysinfo:
GetVolumeInformation() failed: 31' if I run cygcheck -s. It could have
something to do with my system reporting having a e: and f: as a
removable drive. But they don't exist. And I've found no way to remove
them. I get some of the report from cygcheck and there it reports e: and
f: as n/a.

 The 31 means 'A device attached to the system is not functioning.'
acording to the MSDN library. And it happens when cygcheck scans all
possible drive letters. And I guess that this is done to report what
drives is available. And that list includes e: and f: as fd. So it
should not be that generating the error. I'll try to change the code and
compile with added information in the error message.

 Jens Yllman
Uniweb AB                            Phone:  +46 8 626 42 00
P O Box 745                          FAX:    +46 8 626 42 01

Unsubscribe info:
Bug reporting:

More information about the Cygwin mailing list