Variation on: regular user, bash cannot find /tmp

Igor Peshansky
Tue Sep 5 14:35:00 GMT 2006

On Tue, 5 Sep 2006, David LaFrance-Linden wrote:

> I found a few similar problems in your mail archives, but I did not
> quickly find the problem I'm having.  Attached is cygcheck output as
> requested.
> A few days ago, as a normal user on my MS Windows box, I went to
> and ran setup.exe to install things, for "just me".
> Everything seemed to go OK.  When I ran the shortcut, it brought up a
> bash.  First time up it did some setup.  Things worked.
> Then I decided to install it for everyone.  I deleted all the cygwin
> stuff I could find from my directories.  Then, from an Admin account, I
> went to again, ran setup.exe again, and chose "For everyone"
> and put things under c:\cygwin.
> Again, everything seemed to go OK.  But when I, as the original user,
> try the newly installed shortcut on my desktop, I get
>     bash.exe: warning: could not find /tmp, please create!
>     bash-3.1$
> complaint.  The other reports I found seem to indicate it gets further
> than I get.

You probably installed into a different directory for that user, and you
have stale user mounts.  Unfortunately, you have not attached the output
of "cygcheck -svr" from the failing user (which you could have gotten via
"cd c:\cygwin\bin; .\cygcheck -svr" from a command prompt).  Just unmount
all user mounts as the problem user: "cd c:\cygwin\bin; .\umount -U".
      |\      _,,,---,,_ |
ZZZzz /,`.-'`'    -.  ;-;;,_		Igor Peshansky, Ph.D. (name changed!)
     |,4-  ) )-,_. ,\ (  `'-'		old name: Igor Pechtchanski
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

"Las! je suis sot... -Mais non, tu ne l'es pas, puisque tu t'en rends compte."
"But no -- you are no fool; you call yourself a fool, there's proof enough in
that!" -- Rostand, "Cyrano de Bergerac"

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list